Community Forum

Over the years we have built up a community of email marketers, coders and designers that live and breathe email.

Use the Email on Acid Forum like your virtual water cooler: Stop by to discuss email code, quirky clients and fixes and post your issues (with an example of the code) for our community to offer its assistance.

 
   
iOS9 Kinetic build scaling issue

Gwesolo

Newbie
Total Posts:  6
Posted: 12 December 2016 04:34 AM

I’m currently building a kinetic module for an upcoming template but have hit an issue with iOS9 specifically and have reach a head banging desk level of frustration in trying to find a fix.
The module is going to be a carousel but iOS9 seems to be scaling the images to fit the first slide only, despite the images and parent slide elements having fixed widths. I’d also tried using the vw suffix but to no avail. While the images are scaled in, the functionality still seems to be there, the controls work and the .inner container slides as expected.
iOS10 and Apple Mail render fine.

Any help/input would be greatly appreciated!

Code is all present on this JS fiddle: https://jsfiddle.net/ytxmm90b/

Image Attachments
Af159.png

 

Alex Ilhan

Avatar
Administrator
Total Posts:  223
Posted: 13 December 2016 06:57 AM
[ # 1 ]

Hi Gwesolo,

Welcome to the EoA forums!

I’ll have a talk to my fellow email devs here at EoA and see if we can come up with a good solution for you.

Cheers,
Alex


 

Justin Khoo

Avatar
Administrator
Total Posts:  4
Posted: 13 December 2016 04:55 PM
[ # 2 ]

Hi Gwesolo,

Sometimes the iOS client behaves a bit strange when there isn’t a containing table. So when I see scaling issues, the first thing I do is to add a containing table. I was able to see the problem in my iOS 9 iPad and adding a responsive table appeared to fix the scaling issues. Let me know if it works for you.

http://codepen.io/freshinbox/pen/KNGQgR


 

Gwesolo

Newbie
Total Posts:  6
Posted: 10 January 2017 04:04 AM
[ # 3 ]

(a delayed) thanks for the help. Ended up scrapping the divs, rebuilding with nested tables and got that working