Community Forum

Over the years we have built up a community of email marketers, coders and designers that live and breathe email.

Use the Email on Acid Forum like your virtual water cooler: Stop by to discuss email code, quirky clients and fixes and post your issues (with an example of the code) for our community to offer its assistance.

 
   
Not rendering correctly in Outlook

mp3por

Newbie
Total Posts:  4
Posted: 02 November 2016 09:54 AM

Hello,

I am having issues with Outlook. When you look at the test cases you will notice how some of the Outlooks stretch my content, do not break the line, hell even make my blue region extremely big. Does anyone have an idea what is going on.

Test case: https://www.emailonacid.com/app/acidtest/display/summary/RPmF9KLxgX7RcjmpRZ2Dnm5xx2W8VvPhd3AgFU4x7dcOj/shared
code: http://pastebin.com/Ta7rv5Dd

Please help smile


 

Geoff Phillips

Avatar
Moderator
Total Posts:  386
Posted: 02 November 2016 10:33 AM
[ # 1 ]

mp3por,
Welcome to the forum, and thank you for posting!

For some reason, your VML shape was breaking out of its container table. I changed it to the following, and it seems to have fixed the issue.

<!--[if gte mso 9]>
<
v:rect xmlns:v="urn:schemas-microsoft-com:vml" fill="true" stroke="false" style="width:600px;">
<
v:fill type="tile" src="http://reloyalty.com/images/emails/blue-pattern.png" color="#3ab8e4" />
<
v:textbox style="mso-fit-shape-to-text:true" inset="0,0,0,0">
<!
[endif]--> 

 

mp3por

Newbie
Total Posts:  4
Posted: 03 November 2016 03:49 AM
[ # 2 ]

Hey man,

Thank you. This fixed it in everything except Yahoo! Firefox ( Win + Mac) and Yahoo! IE 10-11 ( https://www.emailonacid.com/app/acidtest/display/summary/exHTN1oDetAHBqp7sSZ8K4GOcjMfvqTVZHUwpRmmN6PGA/shared )

What is going on there ?


 

mp3por

Newbie
Total Posts:  4
Posted: 03 November 2016 05:14 AM
[ # 3 ]

Also seen in the same test is that the “pattern” does not render in Outlook 2016 and 2013 ?


 

Geoff Phillips

Avatar
Moderator
Total Posts:  386
Posted: 03 November 2016 09:34 AM
[ # 4 ]

mp3por,
It looks like your link is breaking the container in Yahoo, causing the text to extend outside of it. If you add some line breaks in the link, it will no longer break the container.

As far as the background, in Outlook 2013 this is most likely due to slow loading time on our screenshots. In Outlook 2016, there is a known bug where backgrounds sometimes will not appear until the window is resized. I know, what an annoying bug!

I hope this helps answer your questions. Happy coding!


 

mp3por

Newbie
Total Posts:  4
Posted: 03 November 2016 09:39 AM
[ # 5 ]
Geoff Phillips - 03 November 2016 09:34 AM

mp3por,
It looks like your link is breaking the container in Yahoo, causing the text to extend outside of it. If you add some line breaks in the link, it will no longer break the container.

As far as the background, in Outlook 2013 this is most likely due to slow loading time on our screenshots. In Outlook 2016, there is a known bug where backgrounds sometimes will not appear until the window is resized. I know, what an annoying bug!

I hope this helps answer your questions. Happy coding!

Hello,

Thank you for your support.

“in Outlook 2013 this is most likely due to slow loading time on our screenshots.” -> does this mean that it will render correctly on my clients’ machines ?

“In Outlook 2016, there is a known bug where backgrounds sometimes will not appear until the window is resized. I know, what an annoying bug!” -> does this mean that there is nothing I can do ?

Best regards
Vili


 

Geoff Phillips

Avatar
Moderator
Total Posts:  386
Posted: 03 November 2016 09:45 AM
[ # 6 ]

Vili,
Yes, it will render correctly on their machines in Outlook 2013 given enough time.

No, we don’t know of a fix for this Outlook bug. If we find one we’ll blog about it for sure!