Community Forum

Over the years we have built up a community of email marketers, coders and designers that live and breathe email.

Use the Email on Acid Forum like your virtual water cooler: Stop by to discuss email code, quirky clients and fixes and post your issues (with an example of the code) for our community to offer its assistance.

 
   
Problem with email signature in iPhone mail app (text runs through signature after replies)

michelle88

Newbie
Total Posts:  6
Posted: 23 February 2017 02:00 AM

Hello everybody,

I’ve been working on a signature for my client for a while now, but I keep bumping in to problems. Most of them I have been able to fix myself, but this one I don’t know what to do with and it’s driving my crazy. So I hope someone on here has the solution.

My client uses both Outlook 2013 and 2016. When viewing the signature on the iPhone mail app after a few replies text is running through the signature instead of being underneath the signature. I have no idea why this is happening. Is there anything wrong with my code?

Also on some clients the slogan (which is an image) isn’t always in the middle. It is always in the center of the page. I’ve tried to use vspace instead of margins, but it’s not always working. Really weird thing is that it is working perfectly on my Mac on both Outlook 2007 and 2016, but it isn’t working on my clients Windows machines. If anyone knows a solution for this that would be great too!

I’ve attached the .html file and an image of the problem.

Thanks in advance!

Kind regards,
Michelle

Image Attachments
Schermafbeelding 2017-02-23 om 16.54.10.png
File Attachments
emailhandtekening.html  (File Size: 7KB - Downloads: 55)

 

michelle88

Newbie
Total Posts:  6
Posted: 23 February 2017 07:42 PM
[ # 1 ]

I’ve found a solution for the slogan problem. On the valign attribute I first put “top”, but it should be “middle”. Now the slogan is displaying everywhere in the center and in the middle!

Still haven’t found a solution for the text overlap on the iPhone mail app. I’ve tested in on the Gmail app where it isn’t a problem. So it seems exclusively for the mail app. Can someone please help a newbie out?

Kind regards,
Michelle


 

michelle88

Newbie
Total Posts:  6
Posted: 24 February 2017 02:14 AM
[ # 2 ]

I have fixed the text overlap problem too! I removed a few “align left” attributes which were apparently unnecessary which did the trick. But of course there is now a new problem. I’ll try to explain it as clearly as I can:

When I send an email with the signature from Outlook 2016 (on Mac) to Outlook 2007 (Windows) it looks fine. When I reply to this email everything still is fine. When I then reply to that email that’s when the signature gets messed up. I have added a screenshot and an updated version of the problem.

I have tried to include a screenshot of this, but it’s not working so here is a link to it: http://i557.photobucket.com/albums/ss15/mseters/Schermafbeelding 2017-02-24 om 17.04.36_zpsx9sef5py.png

I hope I’m not a pain, but I really haven’t got a clue how to fix this and IF it is fixable. Google is of no help. Hope someone here knows a solution!

Kind regards,
Michelle

File Attachments
emailhandtekening_outlook_probleem.html  (File Size: 7KB - Downloads: 66)

 

michelle88

Newbie
Total Posts:  6
Posted: 24 February 2017 08:21 PM
[ # 3 ]

On further inspection it seems like Outlook 2007 treats the signature after the replies like images. You can move around the different pieces. Is there a way to force Outlook to stop doing that and just leave the signature alone?
I think it’s also weird that the latest reply is not affected by it. Only the first email send and earlier replies to that email.