Community Forum

Over the years we have built up a community of email marketers, coders and designers that live and breathe email.

Use the Email on Acid Forum like your virtual water cooler: Stop by to discuss email code, quirky clients and fixes and post your issues (with an example of the code) for our community to offer its assistance.

Cellpadding and Outlook 2007


Total Posts:  2
Posted: 28 January 2013 02:30 PM

I’m having a bit of issue with my box model being thrown off in Outlook 2007. It appears that only the first table-row (within the table with cellpadding=“10” set) is getting the padding applied to it. This only happens in Outlook 2007. Any advice?

Screenshot of the bug:
Screenshot of the code:

Any help would be appreciated, thanks!


Michelle Klann

Total Posts:  204
Posted: 28 January 2013 06:03 PM
[ # 1 ]

This is the first I’ve seen this type of issue. Have you tried adding padding in each TD?

Either embedded:

td {padding5px} 

Or inline:

<td style=padding:5px>test</td

If that doesn’t work, can you share a URL with us so we can take a look at the full source?




Total Posts:  2
Posted: 29 January 2013 10:43 AM
[ # 2 ]

I will post the HTML shortly, but I ended up having to break out the different rows within the table with the cellpadding of 10, into individual tables. So, instead of having one table with 10 rows receiving the cellpadding of 10, it’s not 10 tables with 1 row receiving the padding. This fixed the issue but unfortunately produced several more lines of code.

I will post the code shortly for review.



Total Posts:  14
Posted: 31 January 2013 02:33 PM
[ # 3 ]

Try using spacer images as some clients such as outlook 2007 will not render empty cells.